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1. Overview

Qt is a cross-platform graphical application development framework suitable for
devices and platforms of various sizes, offering multiple versions for users to
choose from. The MYD-LD25X series development board utilizes Qt version 5.15.13
for application development. During the Qt application development process, it is
recommended to use the Qt Creator integrated development environment to
develop Qt applications on Linux, while automatically cross-compiling for the ARM

architecture of the development board.

This chapter uses the SDK tools built with Yocto as the cross-compilation toolchain,
combined with Qt Creator to rapidly develop graphical applications.

2. Hardware Resources

» MYD-LD25X Development Board

3. Software Resources

» ubuntu 20.04 64bit

» qt-opensource-linux-x64-5.15.run Series Installation Packages

» Cross-compilation toolchain installation script
myir-image-full-openstlinux-weston-myd-1d25x-x86_64-toolchain-4.2.4-snapshot.
sh(Path:03-Tools/Complie Toolchain)

» MXAPP.tar.gz(PATH: 04-sources/MXAPP))
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4. Environment Preparation

A Ubuntu desktop system is required; all subsequent operations will be carried out
on the Ubuntu 20.04 64-bit version. Please install the desktop system on your own.

® Installing the Cross-Compilation Toolchain

Enter the installed Ubuntu desktop system,copy the cross-compilation toolchain
installation script
myir-image-full-openstlinux-weston-myd-1d25x-x86_64-toolchain-4.2.4-snapshot.
sh to the system, and then run the following command:

myir@ubuntu:~$ ./myir-image-full-openstlinux-weston-myd-1d25x-x86 64-toolch

ain-4.2.4-snapshot.sh

Here we choose to install it to the default path, so that the cross-compilation
toolchain for gcc and g++ will be located in the directory
/opt/st/myd-1d25x/4.2.4-snapshot making it convenient for future configuration.
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5. Installing Qt 5.15

Here,we need to download the installation package qt-opensource-linux-x64-5.
15.run,It includes Qt Creator.However,the Qt official website no longer provide
s offline installation packages for versions below Qt 5.15,s0 please find the re

sources on your own for installation.

® Installing Required Libraries for Qt

Before installing Qt Creator, you need to configure the host environment. Please

install the following resource packages:

myir@ubuntu:~$ sudo apt-get update
myir@ubuntu:~$ sudo apt install --reinstall libxcb-xinerama0
myir@ubuntu:~$ sudo apt install cmake build-essential libgl1-mesa-dev libglu

1-mesa-dev freeglut3-dev cmake

® Place the installation package in Ubuntu and run it.

myir@ubuntu:~$ ./qt-opensource-linux-x64-5.15.run
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1)Enter your Qt account and password. If you haven't registered yet, you will need

to register first. Then, click "Next."

Qt Setup

Welcome to the Qt online installer

Log in to Qt Account
Login
Welcome
Installation Folder
Select Components
License Agreement Don't have Qt account?  Sign uj

The Qt Account will give y
ol iew, and forums

Ready to Install

Installing

Finished

Figure 5-1. Enter Username and Password
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2)Check the two items below, and then click "Next."

Application Note J

Qt setup

Qt Open Source Usage Obligations

Login
e v3 and Lesser GNU General P

Oper rce Obligations W COomp are a\ le under GNU General Public Li

) - Obligations b ; ng the link below helps you ch
Welcome
Installation Folder
Select Components
License Agreement
Ready to Install

Installing

Finished

all and run modified versions of the SW inside them

| have read and agr the terms

I'm an individual and do not use Qt for any

Figure 5-2. Agree to the terms and conditions.
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3)Select 'Reject’ to send a message, and then click 'Next.'

Application Note J

Qt Setup

Contribute to Qt Development

Login Help us im ot ator by allowing tracking of pseudonymous usage data in Qt Creator. The tracking
can be dis
Open Source Obligations Read the Ot Company

Welcome
Contribute to Qt Develop...

Installation Folder

(O Help us to improve by enabling sendin donymous usage statistics in Qt Creator

Select Compone ' .
BRI Disable sending pseudonymous usage statistics in Qt Creator

License Agreement

Ready to Install

Installing

Finished

Figure 5-3. Click the 'Reject’ option.
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4)Select 'Install Components," and then click 'Next.'

Application Note J

Login
Open Source Obligations
Welcome
Contribute to Qt Development
Instal
Select Components
License Agreement
to Install
Installing

Finished

Qt Setup

Installation Folder

Custom Installation

User selectable packages. Host
platform and developer license
restrictions apply.

Qt 6.7 for Android
Automotive

Everything that is required to
develop apps for Android
Automotive DS.

Qt 6.7 for desktop
development
Qt libraries for GCC

(\evelopment tools
Qt 6.7 for mobile
developiment

Qt libraries for Android and i0S
- platform restrictions apply

Qt Design Studio

n of Qt Design

Figure 5-4. Select the 'Install Components' option.
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5)"First, check 'Archive' at location @, then click 'Filter" at location @, and wait for
it to complete.”

Qt Setup

Select Components

Login

Open Source Obligations
Welcome

Contribute to Qt Development

Installation Folder

Select Components

License Agreement
Ready to Install
Installing

Finished

Browse QBSP files

Figure 5-5. Configure Installation Options
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6)After configuration is complete, check '5.15.2," and then click 'Next.’

Qt Setup

Select Components

Login

Open Source Obligations
Welcome

Installation Folder
Select Components
License Agreement
Ready to Install
Installing

Finished

O ¢
O ¢
O«
O Q
m
O«
O «
O «
O ¢
O«
O «
OQ
O ¢
O«
O«
OQ
O ¢
O«
O ¢
O ¢
O ¢
O«
O ¢
OQ
&
O«
0«
=

er and Designer Tools

Figure 5-6. Installation Completed
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7) Click 'Install' and wait for the installation to succeed.

Application Note J

Qt Setup

Installing Qt

Login
Open Source Obligations

cnown time remaining.
Welcome al: 0. unknown time remaining.

Installation Folder

Select Compon

License Agreement

Ready to Install 2D in Qt Gl'aphS

Installing

Finished

click to learn more

Figure 5-7. Waiting for Installation Success
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8) Once installation is successful, click 'Finish.'

Application Note J

Qt Setup

Finished the Qt Setup

Click Finish to exit the Qt Setup.
Login
. Open Ot Design Studio README file
Open Source Obligations

[0 Launch Qt Design Studio

Welcome
; Launch Qt Creator
Installation Folder
Select Components
License Agreement
Ready to Install
Installing

Finished

Figure 5-8. Waiting for Installation Success
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6. Configuring the Cross-Compilation

Environment

1) Navigate to the Tools/QtCreator/bin folder within the Qt installation directory,
and then execute the ./qtcreator command to start Qt Creator.

2) Once in Qt Creator, select Edit->Preference to access the configuration

interface.

Qt Creator

File J2l§ View Build Debug Analyze Tools Window Help

PROJECTS

1D hello

~/hello/CMakeLists.txt

Advanced b
Find/Replace

EXPLORE MORE

A GetStarted

A GetQt

A QtAccount

A Online Community

A flaas
Setup Emscripten SDK for WebAssembly? To do it later, select Edit > Preferences > Devices > WebAssembly. Setup Emscripten SDK | | Do Not Show Again | X

Would you like to configure Android options? This will ensure Android kits can be usable and all essential packages are
installed. To do it later, select Edit > Preferences > Devices > Android.

L. Type to locate (CErl... 1 Iss... 2 SearchResu... 3 Application Out... 4 Compile Out... 5 Termi... 9 GeneralMessa... 2

Configure Android | | Do Not Show Again | X

Figure 6-1. Enter Configuration Interface
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3)Select Compilers to configure the GCC and G++ toolchain.

Application Note -

Qt Creator ol

Preferences — Qt Creator X

Kits

Kits = QtVersions | Compilers Debuggers

Cd Devices Name Add -
i ~ Auto-detected
) Envircnment . C Clone
GCC (C, x86 64bit at Jusr/bin/x86_64-linux-gnu-gcc
B Text Editor v Gt { /us/Din/iBe -gnu-gec) Remove
3 i in/g+
¥ Fakevim ] Manu;cc (C++, x86 64bit at fusr/bin/g++) Remove All
- c Re-detect
@ Help 93-GCC
{} ca+ . GCC (C, arm 64bit at fopt/Fsl-imx-xwayland/6.1-mickledore/sy Auto-detection Settings...
* C++

: Qt Quick 93-G++
Tutorials GCC (C++, arm 64bit at /opt/fsl-imx-xwayland/6.1-mickledore;

Build & Run

Marketplace

EXPLORE MORE Qbs

4
>
A cMake
m

A Getstatel gy Debugger

/s

Get Qt Designer

A
A QtAcomni ' Python
A online Co = Analyzer

[ b

Sort categories

A Blaas
Setup Emscripte

Would you like
installed. To do it

K. Type to locate (Ctrl...

@apply || Ocancel |_QQK \ ,WNDtShW':‘Qﬁi“ *

i || Do Not show Again | X

Figure 6-2. Compilers Configuration Interface
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4)Select 'Add’' on the right side -> 'GCC' -> 'C' and 'Add' -> 'GCC' -> 'G++'

to add a custom GCC and G++ toolchain. Rename the newly added GCC tool
chain to 'LD25X' and choose /opt/st/myd-1d25x/4.2.4-snapshot/sysroots/x86 64
-ostl sdk-linux/usr/bin/aarch64-ostl-linux/aarch64-ost/-linux-gcc. Rename the ne
wly added G++ toolchain to 'LD25X-G++' and choose /opt/st/myd-1d25x/4.2.4
-snapshot/sysroots/x86 64-ostl sdk-linux/usr/bin/aarch64-ostl-linux/aarch64-ost/
-linux-g++. After completing these configurations, click 'Apply' to apply the c

hanges.

Preferences — Qt Creator x

Filter

Og Devices
[J Environment
B Text Editor
M. FakeVim
@ Help

{} s
QtQuick
Build & Run
CMake
Qbs
Debugger

N8P Yy a

Designer
& Python

[E Analyzer

& Version Control
[B Code Pasting

& Language Client

BTl varmina '

Sort categories

Kits
Kits =~ QtVersions = Compilers | Debuggers
Name = Typ¢ Add
~ Auto-detected
-c Clone i
} C“c-:c (C, x86 64bit at /usr/bin/x86_64-linux-gnu-gcc) Gec —
GCC (C++, x86 64bit at Jusr/bin/g++) GCC Remove All
~ Manual
vc Re-detect
GCC (C, arm 64bit at /opt/fsl-imx-xwayland/6.1-mickledore/sysroots/x86_64-pokysdk-linux/usr/bin/aarch64-poky-linux-musl/aarch64-poky-li
Auto-detection Settings...
* O
GCC (C++, arm 64bit at /opt/Fsl-i land/6.1-mickledore/ 5/x86_64-pokysdk-linux/usr/bin/aarch64-poky-linux-musl/aarch64-poky-linux-musl-g++) GCC
LD25X-G#+ GCC
[ v
Name: LD25X-GCC
Compiler path: fopt/st/myd-ld25x/4.2.4-snapshot/sysroots/x86_64-ostl_sdk-linux/usr/bin/aarch64-ostl-linux/aarch64-ostl-linux-gcc Browse...”
Platform codegen flags:
Platform linker Flags:
ABE arm-linux-generic-elf-64bit ~ | arm v - linux ~ - generic ~ - elf ~ - 64bit v
Target triple: aarch64-ostl-linux override for code model
Qapply | Ocancel || @ok | B

X

Configure Android | | Do Not show Again | X

> Devices >

Figure 6-3. Configure GCC Toolchain

Preferences — Qt Creator x 3

Filter

Cd Devices

CJ Environment
B Text Editor
M. Fakevim

@ Help

{} Cos

-4 QtQuick

7 Build &Run
A cmake

M@ Qbs

A Debugger
/" Designer
@ Python

[E Analyzer
Version Control
[& code Pasting

P Language Client
B0 mcminal

Sort categories

Kits
Kits = QtVersions = Compilers = Debuggers il
Name ~ Type Add
~ Auto-detected
v C Clone
. Cﬁcccqc,xms 64bit at fusr/bin/x86_64-linux-gnu-gcc) Gce —— H
GCC (C++, X86 64bit at fusr/bin/g++) [elde Removaall
~ Manual
Te Re-detect
GCC (C, arm 64bit at Jopt/fsl-imx-xwayland/6.1-mickledore/sysroots/x86_64-pokysdk-linux/usr/bin/aarch64-poky-linux-musl/aarch64-poky-linux-musl-gcc)  Gecc
LD25X-GCC GCC | Auto-detection Settings...
v G

GCC (C++, arm 64bit at /opt/fsl-imx-xwayland/6.1-mickledore/sysroots/x86_64-pokysdk-linux/usr/bin/aarch64-poky-linux-musl/aarch64-poky-linux-musl-g++)

Name: LD25X-G++
Compiler path: Jopt/st/myd-d25x/4.2.4-snapshot/sysroots/x86_64-ostl_sdk-linux/usr/bin/aarch64-ostl-linux/aarchéd-osti-linux-g++ Browse...-
Platform codegen flags:
Platform linker flags:
ABI: arm-linux-generic-elF-64bit ~ | arm * - linux ~ |- generic ~ - elf ~ - 64bit -
Target triple: aarch64-ostl-linux Override for code model
Grpply | [Oconcel || @ox | F

X
. Todo it later, select Edit > Preferences > Devices > x

Configure Android | | Do Not Show Again

Figure 6-4. Configure G++ Toolchain
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5)"Select 'Debugger’ and configure 'GDB.' Click 'Add" on the right side to add

a custom GDB configuration. Rename this GDB configuration to 'LD25X-GDB'
and choose the path “Jopt/st/myd-Id25x/4.2.4-snapshot/sysroots/x86 64-ostl s
dk-linux/usr/bin/aarch64-ostl-linux/aarch64-ost/-linux-gdb'. After completing th
e configuration, click 'Apply' to apply the changes."

Preferences — Qt Creator x

Filter

Kits
Cd Devices
[ Environment
B Text Editor
¥ FakeVim
@ Help
{} c++
-4 QtQuick
2 Build &Run
A cMake
B Qbs
i Debugger
/ Designer
@ python
[E Analyzer
B Version Control
[B code Pasting

P Language Client
1 Tarminal
Sort categories

Kits
| kits QtVersions = Compilers | Debuggers
Name ~ Path Add
~ Generic
GDB from PATH on Build Device gdb Clone
LLDB from PATH on Build Device lidb
- Auto-detected Bimove
System GDB at /bin/gdb /binf/gdb
System GDB at fopt/fsl-imx-xwayland/6.1-mickledore/sysroots/x86_64-pokysdk-linux/usr/bin/aarch64-poky-li 1/ h64-poky-li l-gdb Jopt/fsl-i land/6.1-mic|
System GDB at fusr/bin/gdb Jusr/bin/gdb
~ Manual
LD25X-GDB lopt/st/myd-ld25x/4.2.4-snap
Name: LD25X-GDB
Path: Jopt/st/myd-ld25x/4.2.4-snapshot/sysroots/x86_64-ostl_sdk-linux/usr/bin/aarch64-ostl-linux/aarch64-ostl-linux-gdb Browse...”
Type: GDB
ABIs: arm-linux-generic-elf-64bit
Version: 132.0
working directory: Browse...
@apply || @cancel | @ok |

Figure 6-5. Configure GDB

-17 -

MYIR Electronics Limited
Web: www.myirtech.com

Mail: sales@myirtech.com Tel: +86-755-22984836


http://www.myir.cn
http://www.myirtech.com

1R RiREB=
MY i R Make Your Idea Real Application Note -

6)Select 'Qt Versions' and configure '‘QMake." Click 'Add' and choose the path
“/opt/st/myd-1d25x/4.2.4-snapshot/sysroots/x86 64-ostl sdk-linux/usr/bin/qgmake.
After completing the configuration, click 'Apply' to apply the changes.

Preferences — Qt Creator

Filter Kits
m‘ Kits | QtVersions = Compilers Debuggers
Ld Devices Name ~ qmake Path Add...
i ~ Auto-detected
[J Envirenment ® Qts5.15.2 for Android  /home/dhf/Qt/s.15.2/android/bin/gmake Remove
0 Qt 5.15.2 GCC 64bit /home/dhF/Qt/5.15.2/gcec_s4/bin/gmake
B Text Editor © Qt5.15.2 WebAssembly /home/dhf/Qt/5.15.2/wasm_32/bin/qmake —
¥ Fakevi ~ Manual Link with Qt...
% FakeVim = = inf
Otk Clean Up
elp
{} c++
-4 QtQuick
7 Build & Run
A cMake
B Qbs
% Debugger
7/ Designer
@ Python
[E Analyzer
Version Control Name: Qt %{Qt:Version} (System)
I Code Pasting qmake path: Jopt/st/myd-ld25x/4.2.4 hot/sy: /x86_64-ostl_sdk-linux/usr/bin/qmak | Browse... |
P Language Client Qt version 5.15.9 for Desktop Details ~
B Tacmina 2
3 N Register documentation: | Highest Version Only ~
Sort categories

@apply || @cancel | @ok

Figure 6-6. Configure QMAKE
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7)Select 'Kits' to configure the cross-compilation toolchain. Click '‘Add’ on the right

to add a custom Kit configuration. Rename it to 'LD25X-KIT," and set the Compiler,
Debugger, and Qt Versions to the previously configured items. Click 'Apply' to
apply the changes. If no warnings or errors appear, the toolchain configuration is
complete.

Preferences — Qt Creator x

Filter Kits
m‘ Kits | QtVersions Compilers Debuggers
Cd Devices Name i Add
) ~ Auto-detected
) Environment 2 Desktop QL 5.15.2 GCC 64bit Clone
= il Python2.7.18 =
Text Editor 2 python 3.8.10 (default) Emove
= Python3.11.5
¥. Fakevim Qt 5.15.2 WebAssembly Make Default
- Manual Settings Filter...
O Hep E
{} c++ Default Settings Filter...
4 ot Quick Name: LD25X-kit =
2 Build & Run File system name:
A cMake Run device type: Remote Linux Device
@ Qbs Run device: @ MYD-LD25X-Board (default For Remote Linux) ~ | Manage...
¥ Debugger Build device: Desktop (default for Desktop) ~ | Manage...
7 [ LD25X-GCC
Designer Compiler: Manage...
& eyt Ct41 | LD25X-G++
= Al Environment: No changes to apply. Change...
= Analyzer
VerioncenEal Debugger: LD25X-GDB ~ || Manage...
‘ersion Control
& cod X Sysroot: Jopt/fsl-imx-xwayland/6.1-mickledore/sysroots/x86_64-pokysdk-linux Browse...
Code Pasting
» ; Qt version: Qt 5.15.9 (System) ~ | Manage...
Language Client
— . | Qtmkspec:
1 Tarminal
Sort categories Additional Qbs Profile Settings: Change... | |,
©rpply || @gcancel || @ok |

Figure 6-7. Configure Kit
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8)Copy MXAPP.tar.gz to a working directory in Ubuntu and extract the source code.

Configure it with the appropriate toolchain. From the menu bar, select 'File' ->
'Open File or Project,” then browse to the 'MXAPP2' directory in the working
directory and choose the mxapp2.pro file. Click 'Open.’ Once the project is opened,

select the 'Projects’ icon in the left menu to switch to the manage kits interface.
Under the 'Build & Run' tab, select the 'LD25X-KIT' option to use its configuration
for building the application. Then, right-click on 'mxapp2' and click 'Build.’

[MXAPP2-Qt5-novideo] - mxapp2 - Qt Creator

File Edit View Build Debug Analyze Tools Window Help

FM 2. Filter aF =

Manage Kits... Run Settings
Welcome

Active Project Deployment
mxapp2 ¥ Method: Deploy to Remote Linux Host ~ Add - | Remove | Rename..

Import Existing Build... Files to deploy:

/ Build = Override deployment data from build system
» Run Source File Path Target Directory
2 Lp25x-kit /home/dhF/LD25X/MXAPP2/build/LD25X_kit-Debug/mxapp2 Jopt/mxapp2/bin

7 Bulld i — |

Issues s~ v A T PRI

declared here gsharedpo...mpl.h:562
‘T* QWeakPointer<T>::data() const [with T = QCPAbstractPaintBuffer... data() on the returned QSharedPointer [-Wdeprecated-declarations]  gcustompl...cpp:13900

+ declared here qsharedpo...mpl.h:562
» ‘QPoint QWheelEvent:pos() const’ is deprecated: Use position() [-Wdeprecated-declarations] qcustompl...cpp:14672
v declared here qevent.h:225
» ‘QMap<K, V>uiterator QMap<K, V>uinsertMulti(const Key&, const T&) ...oring multiple values with the same key. [-Wdeprecated-declarations] qcustompl...cpp:15017
+ declared here gqmap.h:1366
» ‘int QwheelEvent:delta() const’ is deprecated: Use angleDelta() [-wdeprecated-declarations] qcustompl...cpp:17623
v declared here qevent.h:219
|:l ‘QPoint QwheelEvent::pos() const’ is deprecated: Use position() [-Wdeprecated-declarations] qcustompl...cpp:17630
LR + declared here qevent.h:225
Debug ‘QPoint QWheelEvent:pos() const’ is deprecated: Use position() [-Wdeprecated-declarations] qcustompl...cpp:17639
declared here qevent.h:225
‘constexpr QFlags<T>::QFlags(Zero) [with Enum = Qt::Orientation; Zer...recated: Use default constructor instead [-Wdeprecated-declarations] gcustompl...cpp:19266
declared here gflags.h:123

‘constexpr QFlags<T>::QFlags(Zero) [with Enum = Qt::Orientation; Zer...recated: Use default constructor instead [-Wdeprecated-declarations] qcustompl...cpp:19286
declared here qflags.h:123
unused variable ‘i' [-Wunused-variable gmiplot.cpp:94 -
L. Type to locate (Chrl... 1@ 2 Searc... 3 Applicatio... 4 Compil... 5 6 Versio... 7 Te... 8 QMLDebugge... 9 General... 3

Figure 6-8. Select LD25X-KIT for Compilation
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File Edit View B Debug Analyze Tools Window Help
Projects <no document>
~ [ mxapp2 [MXAPP2-Qt5-novid

@ MXapp2.pro

Welcome [ I'! Headers

Application Note

[MXAPP2-Qt5-novideo] - mxapp2 - Qt Creator

» lk.i Other files

Open a document

Extensions

®

Compile Output fadl A Filter =
Tinuxfusr/1ib/1ibatsMultinediaWidgets. so Jopt/st/myd- umm 2.4-snapshot/sysroots/cor texa35-ostL-linux/usr/1ib/1ibQtSWidgets.so /opt/st/myd-1d25x/4.2.4-snapshot/sysroots /cortexa3s- =
ostl-Tinux/usr/1ib/1ibgtsMultinedia.so /opt/st/myd-1d . pshot/sysroots/cor -ostl-linux/usr/1ib/1ib0t56ui.s0 /opt/st/myd-1d25x/4.2.4-snapshot/sysroots/cortexa3s-ostl-
Tinux/usr/1ib/1ibotsqnlmodels. so fopt/st/myd-1d25x/4.2.4~: 5nap§h0(/Sysrocts/(crtexajs -ost1-Tinux/usr/1ib/1ibtsoml.so fopt/st/myd-1d25x/4.2.4-snapshot/sysroots/cor texa3s-ostl-Tinux/
usr/1ib/1ibQtsNetwork.so /opt/st/myd-1d25x/4.2.4-snapshot/sysroots /cortexa3s-ost1-Tinux/usr/1ib/1ibQtsTest . so /opt/st/myd-1d25x/4.2.4-snapshot /sysroots/ cor texa3s-ostl-linux/usr/1ib/
hbqts(ure so -1GLESv2 -lpthread

EFETE /R xfond oermasy

: Elapsed time: 15:

2 searchRes... 3 ApplicationOut... 4 Compile Out... 5 Termi. 6 Version Con... 7 TestRes... 8 QML DebuggerCons... 9 GeneralMessa... =

Figure 6-9. Compilation complete

After building the mxapp project in QtCreator, the compiled binary files will be
stored in the specified directory. Copy the mxapp file to the development board

and run it.

[MXAPP2-Qt5-novideo] - mxapp2 - Qt Creator

File Edit View Build Debug Analyze Tools Window Help

Manage Kits... Build Settings
Welcome Edit build configuration: Debug ~ Add - | Remove | Rename..|| Clone..
Active Project General
mxapp2 ~
Shadow build: v
Import Existing Build... Build directory: I /home/dhF/LD25X/MXAPPZ/build/LD25X_kit-Debug Browse...” I
Debug /7 Build = Tooltip in target selector:
Pan Separate debug info: Default
S LGk parate debug info: efau
QML debugging and profiling: Enable ~] /4 Micht make your spplication vilneratle
P Run g
[ Qt Quick Compiler: Default v
B gmake system() behavior when parsing: Use global setting -
]
L =
Hide Inactive Kits Build Steps
Project Settings qmake: gmake mxapp2.pro Details ~
Editor Make: make -j4 in /home/dhf/LD25X/MXAPP2/build/LD25X _kit-Debug Details ~
Language Server
Code style Add Build Step-
Documentation Comments
Dependencies Clean Steps
Environment
C+ File Naming Make: make clean 4 in fhome/dhf/LD25X/MXAPP2/build/LD25X_kit-Debug Details ~
clang Tools

Issues
» declared here gsharedpointer_impl.h:562

“T* QWeakPointer<T>:data() const [with T = QCPAbstractPaintBuffer]' is deprecated: Use toStrongRef() instead, and data() on the returned QSharedPointer [Wdeprecated-declarations] qeustomplot.cpp:13500
» declared here qsharedpointer_implh:562
» ‘QPoint QWheelEve 0s() const’ is deprecated: Use position() [(Wdeprecated-declarations] qecustomplot.cpp:14672
+ declared here qeventh:225
» ‘QMap<K, V>riterator QMap<K, V=zinsertMulti(const Key&, const T&) [with Key = int; T = QPa...se QMultiMap for maps storing multiple values with the same key. [-wdeprecated-declarations] gcustomplot.cpp:15017
+ declared here qmap h:1366

R. Type to locate (Ctrl.

Figure 6-10. Save path
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7. References

® Ubuntu Desktop Download Address:

https://releases.ubuntu.com/20.04/

® QT Development Guide

https://www.qt.io/

-22 -

MYIR Electronics Limited
Web: www.myirtech.com Mail: sales@myirtech.com Tel: +86-755-22984836


https://releases.ubuntu.com/20.04/
https://www.qt.io/
http://www.myir.cn
http://www.myirtech.com

MY R kr@Bx
Make Your Idea Real

Application Note J

Appendix A

Warranty & Technical Support Services
MYIR Electronics Limited is a global provider of ARM hardware and software tools, design solutions for

embedded applications. We support our customers in a wide range of services to accelerate your time to
market.

MYIR is an ARM Connected Community Member and work closely with ARM and many semiconductor
vendors. We sell products ranging from board level products such as development boards, single board
computers and CPU modules to help with your evaluation, prototype, and system integration or creating
your own applications. Our products are used widely in industrial control, medical devices, consumer
electronic, telecommunication systems, Human Machine Interface (HMI) and more other embedded
applications. MYIR has an experienced team and provides custom design services based on ARM
processors to help customers make your idea a reality.

The contents below introduce to customers the warranty and technical support services provided by MYIR
as well as the matters needing attention in using MYIR’s products.

Service Guarantee

MYIR regards the product quality as the life of an enterprise. We strictly check and control the core board
design, the procurement of components, production control, product testing, packaging, shipping and
other aspects and strive to provide products with best quality to customers. We believe that only quality
products and excellent services can ensure the long-term cooperation and mutual benefit.

Price

MYIR insists on providing customers with the most valuable products. We do not pursue excess profits
which we think only for short-time cooperation. Instead, we hope to establish long-term cooperation and
win-win business with customers. So we will offer reasonable prices in the hope of making the business
greater with the customers together hand in hand.

Delivery Time

MYIR will always keep a certain stock for its regular products. If your order quantity is less than the
amount of inventory, the delivery time would be within three days; if your order quantity is greater than
the number of inventory, the delivery time would be always four to six weeks. If for any urgent delivery,
we can negotiate with customer and try to supply the goods in advance.

Technical Support
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MYIR has a professional technical support team. Customer can contact us by email

Application Note J

(support@myirtech.com), we will try to reply you within 48 hours. For mass production and customized

products, we will specify person to follow the case and ensure the smooth production.

After-sale Service

MYIR offers one year free technical support and after-sales maintenance service from the purchase date.

The service covers:

Technical support service

MYIR offers technical support for the hardware and software materials which have provided to customers;

> To help customers compile and run the source code we offer;

> To help customers solve problems occurred during operations if users follow the user manual
documents;

> To judge whether the failure exists;

> To provide free software upgrading service.

However, the following situations are not included in the scope of our free technical support service:

> Hardware or software problems occurred during customers’ own development;

» Problems occurred when customers compile or run the OS which is tailored by themselves;

> Problems occurred during customers’ own applications development;

> Problems occurred during the modification of MYIR’s software source code.

After-sales maintenance service

The products except LCD, which are not used properly, will take the twelve months free maintenance

service since the purchase date. But following situations are not included in the scope of our free

maintenance service:

> The warranty period is expired;

> The customer cannot provide proof-of-purchase or the product has no serial number;

» The customer has not followed the instruction of the manual which has caused the damage the
product;

> Due to the natural disasters (unexpected matters), or natural attrition of the components, or
unexpected matters leads the defects of appearance/function;

> Due to the power supply, bump, leaking of the roof, pets, moist, impurities into the boards, all those
reasons which have caused the damage of the products or defects of appearance;

> Due to unauthorized weld or dismantle parts or repair the products which has caused the damage of

the products or defects of appearance;

-24-

MYIR Electronics Limited
Web: www.myirtech.com Mail: sales@myirtech.com Tel: +86-755-22984836


http://www.myir.cn
http://www.myirtech.com

s IRINEB=
MY . R Make Your Idea Real Application Note J

> Due to unauthorized installation of the software, system or incorrect configuration or computer virus

which has caused the damage of products.

Warm tips

1. MYIR does not supply maintenance service to LCD. We suggest the customer first check the LCD when

receiving the goods. In case the LCD cannot run or no display, customer should contact MYIR within 7

business days from the moment get the goods.

2. Please do not use finger nails or hard sharp object to touch the surface of the LCD.

3. MYIR suggests user purchasing a piece of special wiper to wipe the LCD after long time use, please

avoid clean the surface with fingers or hands to leave fingerprint.

4. Do not clean the surface of the screen with chemicals.

5. Please read through the product user manual before you using MYIR's products.

6. For any maintenance service, customers should communicate with MYIR to confirm the issue first. MYIR’

s support team will judge the failure to see if the goods need to be returned for repair service, we will

issue you RMA number for return maintenance service after confirmation.

Maintenance period and charges

> MYIR will test the products within three days after receipt of the returned goods and inform customer
the testing result. Then we will arrange shipment within one week for the repaired goods to the
customer. For any special failure, we will negotiate with customers to confirm the maintenance period.

» For products within warranty period and caused by quality problem, MYIR offers free maintenance
service; for products within warranty period but out of free maintenance service scope, MYIR provides
maintenance service but shall charge some basic material cost; for products out of warranty period,
MYIR provides maintenance service but shall charge some basic material cost and handling fee.

Shipping cost

During the warranty period, the shipping cost which delivered to MYIR should be responsible by user;

MYIR will pay for the return shipping cost to users when the product is repaired. If the warranty period is

expired, all the shipping cost will be responsible by users.
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MYIR will always select mainstream chips for our design, thus to ensure at least ten years continuous

supply; if meeting some main chip stopping production, we will inform customers in time and assist
customers with products updating and upgrading.

Value-added Services

1. MYIR provides services of driver development base on MYIR’s products, like serial port, USB, Ethernet,
LCD, etc.

2. MYIR provides the services of OS porting, BSP drivers’ development, APl software development, etc.
3. MYIR provides other products supporting services like power adapter, LCD panel, etc.

4. ODM/OEM services.

MYIR Electronics Limited

Room 04, 6th Floor, Building No.2, Fada Road,

Yunli Inteiligent Park, Bantian, Longgang District.

Support Email: support@myirtech.com

Sales Email: sales@myirtech.com

Phone: +86-755-22984836

Fax: +86-755-25532724

Website: www.myirtech.com
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